Start a conversation

Migrating a TracerPlus Connect installation to another PC/Server

It is a common request to move a production installation of a TracerPlus Connect installation from one PC to the next. The following is a guideline for steps to consider in this migration. Note that steps 1 - 3 are also useful when setting up a Satellite PC

 

1. Exporting your TracerPlus Connect project

To export your TracerPlus Connect project from the original PC, simply select the File-->Export menu option within the TracerPlus Connect Management Studio. This will create a file with a “.tce” extension that can be used to File-->Import to the new PC.

NOTE:  The suggestions following this bullet item are very important for a successful TracerPlus Connect server migration in most cases.

 

2. Data Source considerations

Whether you are using ODBC, Text files, or Excel files, there needs to be some pre-configuration considered *before* importing your TracerPlus Connect exported project.

  • For ODBC:  Be sure that the DSN (Data Source Name) you are using has been created and functioning with the same name as configured in your TracerPlus Connect project. If you are running 64 bit Windows, this DSN must be created using the 32 bit ODBC Administrator (C:\Windows\SysWow64\odbcad32.exe).
  • For text and Excel files:  All source or destination files must be pre-created before importing your TP Connect exported project and should be placed in an identical file path as the previous install.

 

3. Linked TracerPlus Desktop Projects

If you are using a linked TracerPlus Desktop project (not required), you must have this project already loaded on the destination PC *before* importing your TracerPlus Connect exported project.  Generally, performing a File-->Export in TracerPlus Desktop on the original PC is the easiest way to then File-->Import this project to the destination PC.

NOTE: This project *must* be located in the same *exact* path as referenced in your TracerPlus Connect project. Ideally, it would not be saved to a user folder (like \My Documents) but better saved to some generic folder like “c:\TracerPlus” or similar. If you do not save this project to same path, you will be prompted to locate your desktop project during the import process.

 

4. TracerPlus Connect registration and device registration

Transfer of a TracerPlus Connect license requires a license transfer from one PC to another. This needs to be arranged beforehand with your PTS sales representative. Normally, an active support agreement is required to initiate this transfer. 

  1. When the new PC has been fully configured following the steps above, a new registration code is required to register this new PC.
  2. For the devices, it is normally ok to simply allow the devices to self-register on this new PC if the option to “Auto-register” is checked in the TracerPlus Connect Tools-->Registration menu option.




Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Joseph Kraebel

  2. Posted
  3. Updated

Comments